Fırat Boyan | MCT- Microsoft Certified Trainer.



Beğendiğiniz içerikleri sosyal medya üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.

category KATEGORİ: Routing-Switching
category Fırat Boyan category 28.03.2017 category 3

Cisco Router Üzerinde DHCP Ayarları


Bu makalemde sizlere Cisco Router Üzerinde DHCP Ayarları yapılandırma işleminden bahsediyor olacağım.

DHCP (Dinamic Host Configuration Protocol) bir network'teki istemcilerin (client) IP, Varsayılan Ağ Geçidi (Default Gateway) , Alt Ağ Maskesi (Subnet Mask), Etki Alanı (Domain), DNS gibi yapılandırmalarını otomatik olarak almasını sağlayan bir protokoldür.

DHCP; çok sayıda istemcinin (client) bulunduğu network ortamlarında, kullanıcıların bu bilgileri girerken yaşabileceği zorlukları aşarak hem zamandan hem de IP bloğundan tasarruf sağlar. Ayrıca, statik olarak atanan IP adreslerini, o network'te IP çakışmalarına da neden olacaktır. Cisco marka router'lar, harici bir DHCP sunucusuna gereksinim duymadan tüm istemcilere bu bilgileri sağlayabilmektedirler. Router'ların (yönlendiricilerin) bu özelliği sayesinde DHCP, IP dağıtma ihtiyacınımızı da Server bilgisayarlara kurmadan karşılayabilmekteyiz. Bu, server bilgisayarımızın perfomansından da tasarruf yapmamız anlamına geliyor. Şunu da özellikle belirtmeliyim ki; Cisco Router Üzerinde DHCP Ayarlarının yapılması, ortamda server üzerinde DHCP rolünün kurulması gereksinimini de ortadan kaldıracaktır.


cisco router DHCP

Örnek yapılandırma aşağıda gibi olacaktır:

Router#config t
Router(config)#interface gigabitEthernet 0/1

//İç Network bacağı (aynı zamanda Default Gateway (varsayılan ağ geçidi))
Router(config-if)#ip address 10.10.10.1 255.255.255.0
//İç Network bacağına IP ataması
Router(config-if)#no shutdown
//İç Network bacağının açılması

Router(config)#service dhcp
Router(config)#ip dhcp pool 10network

//dhcp pool oluşturma. 10network, benim verdiğim bir isim
Router(dhcp-config)#network 10.10.10.0 255.255.255.0
// Network ID (ağ adresi)
Router(dhcp-config)#default-router 10.10.10.1
// Default Gateway (varsayılan ağ geçidi)
Router(dhcp-config)#dns-server 10.10.10.100
// DNS sunucusu (Ortamda Server varsa)
Router(dhcp-config)#domain-name firatboyan.com
// Domain (Etki Alanı-ortamda yapılandırılmış ise)
Router(dhcp-config)#lease 0 0 15
//Lease time (adresin kira süresi (gün saat dakika formatında 15 dakikaya ayarlanmış))
Router(config)#ip dhcp excluded-address 10.10.10.1 10.10.10.10
//Ayrılacak (dağıtılmayacak) olan IP adreslerinin aralığı

İstemci sayısının fazla olduğu network ortamlarında DHCP’den dağıtılan IP adres bilgilerinin router üzerinde tutulmasının yanı sıra, FTP veya TFTP sunucu gibi bir ortamda tutulması için ise aşağıdaki komut kullanılır:

Router(config)#ip dhcp database tftp://10.10.10.250/dhcptftp
//dhcptftp adlı dosya oluşturulur (TFTP)
Router(config)#ip dhcp database ftp://kullanıcı:parola@host/dosya adı

Komutların Sade hali:
Router>en
Router#config t
Router(config)#interface gigabitEthernet 0/1
Router(config)#ip address 10.10.10.1 255.255.255.0
Router(config)#no shutdown

Router(config)#service dhcp
Router(config)#ip dhcp pool 10network
Router(dhcp-config)#network 10.10.10.0 255.255.255.0
Router(dhcp-config)#default-router 10.10.10.1
Router(dhcp-config)#dns-server 10.10.10.100
Router(dhcp-config)#domain-name firatboyan.com
Router(dhcp-config)#lease 0 0 15
Router(dhcp-config)#ip dhcp excluded-address 10.10.10.1 10.10.10.10


Cisco router'lar, üstündeki bu yapılandırmayla harici bir sunucuya gerek kalmadan DHCP sunucu hizmeti sağlanmış olur.

Cisco yönlendiriciler ile IP rezervasyonu denilen, belirli bir IP adresini bir istemciye atama işlemi de yapmak mümkündür.

Faydalı olması dileğiyle...
 


Beğendiğiniz içerikleri facebook, twitter, g+1 veya LinkedIn üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.


Her türlü görüş ve önerilerinizi aşağıdaki YORUM panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.

YAZAR HAKKINDA:

Microsoft Certified Trainer-MCT.
Microsoft Certified Solution Expert-MCSE: Cloud Platorm and Infrastructure.

Adım Fırat Boyan. Bilgi Teknolojileri Sistem ve Ağ Mühendisiyim. 1985 Alanya doğumluyum. 2008 yılından beri İstanbul'da yaşıyorum. 15 yıldır Bilişim Teknolojileri sektöründeyim.

2003 yılında lise eğitimimden sonra bir bilgisayar teknik servisinde önce stajyer, sonrasında ise teknik servis teknisyeni olarak başladığım bilişim sektörü çalışma hayatıma, üniversite eğitimimi tamamladıktan sonra, çeşitli şirketlerin bilgi işlem departmanlarında Sistem Destek Uzmanı, IT Uzmanı, IT Sistem Sorumlusu ve IT Sistem Yöneticisi olarak devam ettim ve çok çeşitli projelerde aktif rol alıp Sistem ve Network alanında ciddi deneyimler edinerek bilgime bilgi, tecrübeme tecrübe kattım.

JP. Morgan Chase Bank'ta Sistem Uzmanı ve Analisti olarak görev yapıyor, Türkiye’nin bilişim eğitimleri alanında hizmet veren Bilgi Tekolojileri Eğitim Merkezleri olan Bilge Adam’da MCT-Microsoft Certified Trainer (Microsoft Sertifikalı Eğitmen) ünvanı ile Sistem, Network ve Güvenlik eğitimleri veriyor, kurumsal firmalara Bilişim Teknolojileri Danışmanlık Hizmetleri sunuyorum.

Sertifikalarım:

MCT (Microsoft Certified Trainer)- 2016/2017 - 2017/2018 - 2018/2019
MCPS (Microsoft Certified Professional)
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2012
MCSE (Microsoft Certified Solutions Expert)- Server Infrastructure
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2017
MCSE (Microsoft Certified Solutions Expert)- Messaging
MCSE (Microsoft Certified Solutions Expert)- Productivity 2017
MS (Microsoft Specialist)- Designing and Deploying Microsoft Exchange Server 2016
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2016
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2018
MCSE (Microsoft Certified Solutions Expert)- Productivity 2018




comment YORUMLAR
Bu makaleye 3 yorum yapıldı.

Her türlü görüş ve önerilerinizi aşağıdaki yorum panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.


YORUM YAZ

   
  
(yorum onay bildirimi için gereklidir, yayınlanmaz.)
  750 Karakter yazabilirsiniz.
   
Güvenlik kodunu BÜYÜK harflerle giriniz.

* Yorumlar, onaylandıktan sonra yayınlanmaktadır.




YAPILAN YORUMLAR


04-09-2017


Serkan yıldız

Hocam merhabalar. Sizin seviyenizin bayağı bir altında olacak ama cevaplarsaniz sevinirim. Heponline internet servis sağlayıcısinin Cisco ve tplink routerlarla konfigürasyonuna denk geldim. 2 acces point ekledim (DHCP leri kapalı ve giriş iplerini degistirip) garip olan acces point ten baglanp 192.168.1.1 yazdığımda Cisco ya bağlanıyor. Tplink ve Cisco aynı ip ye sahip ciscoyu 1.5 yapınca 1.1 yazdığımda tplink e erişemiyorum. Sistemdeki sorun bağlanan cihazların 5 10 dk içinde internete çıkamaz hale gelmesi. İki router in da DHCP özelliği açık olduğu için olduğunu düşünüyorum. Yardiminiz için şimdiden çok teşekkür ederim.



06-07-2017


Levent Yüksel

İşime yaradı teşekkürler.


06-07-2017


Fırat Boyan

İşinize yaramasına sevindim. Faydalı olası güzel.






BT EĞİTİM

Kurumsal eğitimler veren bir Microsoft Sertifikalı IT eğitmeniyim. IT Danışmanlık Hizmetleri verdiğim kurumlarda sürekli olarak, bilgi işlem personellerinin yaptığı işleri genelde ezbere ve neden yaptıklarını tam olarak kavrayamadan, bilmeden yaptıklarına şahit oldum. Böyle durumlarda da genelde firmalar, çalışanlarına IT eğitimleri aldırarak, daha profesyonel ve biliçli personeller istihdam etmektedirler. Sizler de kurumunuzda istihdam ettirdiğiniz bilgi işlem personellerinize IT Eğimleri aldırarak, kurumsal olarak yeni teknolojilere daha güçlü ve bilinçli geçişler yaparak ya da mevcut teknolojiler ile yapılandırılmış alt yapınızın bilgi işlem personelleriniz tarafından bilinçli ve profesyonel olarak ayakta tutmasını ve yürütmesini sağlayabilirsiniz.

Detaylar »





BT DANIŞMANLIK

Kendi bünyesinde IT departmanı isitihdam etmeyen ve bu hizmeti danışmanlık kapsamında outsource olarak alan firmalar, bilgisayar sistemlerinin bakımı ve onarımı için profesyonellerden bakım anlaşması kapsamında hizmet talep etmektedirler. Bilişim sektöründe danışmanlık önemli bir konudur. Bu nedenle, işinin ehli olmayan kişilere sisteminizi emanet edemezsiniz. Profesonel IT Uzmanı olarak; işletmelerin Kurumsal IT ihtiyaçlarına yönelik IT ekipmanlarının ve sistemlerinin kurulum,bakım ve konfigürasyonlarının yapılması hizmetlerini sunuyorum.

Detaylar »





İLETİŞİM

Taleplerinizi iletişim formu aracılığıyla direkt olarak bana iletebilirsiniz.
İletilerinize cevap verebilmem için mutlaka gerçeli bir e-posta adresi girin. Gönderdiğiniz iletiler en kısa sürede cevaplanacaktır. Girdiğiniz bilgiler asla üçüncü taraflarla paylaşılmaz. İletilerinizi iletişim formu aracılığı ile direkt olarak iletebileceğiniz gibi, kendi e-posta sunucunuzu kullanarak da mail adresime iletebilirsiniz.

İletişim Formu »