Fırat Boyan | MCT- Microsoft Certified Trainer.



Beğendiğiniz içerikleri sosyal medya üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.

category KATEGORİ: Routing-Switching
category Fırat Boyan category 28.10.2018 category 0

OSPF (Open Shortest Path First- İlk Açık Yöne Öncelik) Protokolü ile Dinamik Yönlendirme


Daha önceki makalemde Distance Vector Protocol'lerden olan RIPv2 ve IGRP Dynamic routing (dinamik yönlendirme) Protokollerinden bahsetmiştim.

Bu malemde de, Link State Dynamic routing protokolü olan OSPF (Open Shortest Path First- İlk Açık Yöne Öncelik) protokolünden bahsedeceğim.

OSPF’nin Özellikleri

Max. Hop değeri: OSPF'te hop sınırlaması yoktur. Router'lar birlerine Point-to-Point bağlıdırlar.
AREA: OSPF, Area(Alan) mantığı üzerinde çalışır. Area0, backbone area olarak kabul edilir.
Administrative Distance-Metric: 110'dur.
Metrik: Metrik hesaplaması olarak Cost Calculation kullanılır. Buna göre en düşük maliyetli yol, en iyi yoldur. Cost Calculation bilgisi, router routing table'a yazılır. Oluşturulan veri tabanı sayesinde network (ağ) içerisinde yol bilgisi ve mesafe hesaplaması otomatik yapılır. SPF (Shortest Path First) algoritması ile network (ağ) toplojisi çıkar ve her 10 sn'de bir değişiklik var mı, yok mu diye Hello paketleriyle yoklama çeker.
Trigger Update mantığıyla çalışır.
Subnet mask üzerinde Netmask yerine Wildcard Mask kullanılır. Wilcard Mask, Netmask'ın eksi değerli karşılığıdır.

Ör.
Netmask: 255.255.224.0
Wildcard Mask: 0.0.31.255
255-224=31

Netmask: 255.240.0.0
Wildcard Mask: 0.15.255.255
255-240=15

Netmask: 252.0.0.0
Wildcard Mask: 3.255.255.255
255-252=3


NOT: Wildcard Mask, sadece router'ların kendilerine bağlı bacaklarında network tanımlaması yaparken kullanılacaktır.
Netmask, Router'ların port'larına IP adresi tanımlama yaparken kullanılacaktır.

OSPF Çalışma Mantığı

OSPF’nin Özellikleri bölümünde belirtilen bilgileri biraz daha açalım.

1- Bir Link State Protokolü olan OSPF, Distance Vector Protocole'ler de olduğu gibi update table mantığında değil, komşu router'larının UP olup olmadıklarını anlamak için hedefe gidilecek en kısa yolu (Shortest Path) seçer ve her 10 saniyede bir değişiklik var mı, yok mu diye küçük Hello” paketleri gönderirler.

OSFP Yapılandırması

Hello paketi içerisinde yer alan bilgiler:

Hello and Dead Interval: 10 saniye de bir gönderilen hello paketlerinin süresidir.
Neighbors: İletişimde bulunan komşuların sayısıdır.
Area ID: OSPF prokolü AREA mantığı ile çalışır ve iletişim kuran router'ların area ID'leridir.
Bu AREA yapısında omurga alan (backbone area) area 0'dır ve her OSPF topolojisinde mutlaka area0 olmak zorundadır.

Router ID: Router'ı tanımlayan 32-bit'lik ve tek olan numaradır.
- Router ID, Router'ın aktif olan interface'ndeki en yüksek IP adresidir. Yani aktif olan interface'lerdeki en büyük IP adresi, o Router'ın ID'sidir.

NOT: Router'da loopback IP adresi tanımlanmışsa ki genelde tanımlanır; o Router'ın ID'si, loopback adresidir. IP adresinin küçük veya büyük olması durumu değiştirmez, burada loopback adresinin böyle bir ayrıcalığı vardır. Ancak birden fazla loopback IP adresi tanımlanmışsa, burada da yine en büyük loopback IP adresi, o Router'ın ID'si olur.

Ör1.
Router1 ip1 1.1.1.1
Router1 ip2 2.2.2.2
Burada en büyük IP adresi 2.2.2.2 olduğu için, Router ID'si de budur.


DR & BDR IP Adresses: Network'ün DR(Designated Router) ve BDR(Backup Designated Router) adresidir.
- DR(Designated Router): Network'teki yönlendirme bilgilerini kendine toplayıp diğer Routerlara dağıtır.
- BDR(Bacup Designated Router): DR'ın yedeği olarak çalışır ve DR aktif olmadığı durumda BDR devreye girer.
- DR ve BDR seçimi, Router ID'lerine göre yapılır. Network'teki en yüksek Router ID'ye sahip Router, DR olarak seçilir ve ikinci en büyük Router ID'ye sahip Router ise BDR olarak seçilir.

Ör1.
Router1 ip 1.1.1.1
Router2 ip 2.2.2.2
Burada;
Router2 DR olur.
Router1, BDR olarak seçilir.


Router Priority: İletişimde kullanılan 8-bit'lik sayıdır.
-En yüksek Priority değerine sahip olan Router, DR olarak seçilir. Eğer router'ların priority değeri aynı ise, ki varsayılan olarak priority değer 0'dır, bu sefer de Router ID değeri en yüksek olan router DR olarak seçilir. Bu da yukarıda anlattığım gibi Router ID, Router'ın aktif olan interface'ndeki en yüksek IP adresidir.

NOT: Priority değeri 0 olan router, asla DR/BDR seçim işleminde yer almaz.

Ör1.
Router1 priority 1 ip 1.1.1.1
Router2 priority 1 ip 2.2.2.2
Burada;
Router2, DR olur.
Router1 ise BDR olarak seçilir.

ör2.
Router1 priority 1 ip1 1.1.1.1
Router1 priority 1 ip2 2.2.2.2
Router2 priority 1 ip1 3.3.3.3
Router2 priority 1 ip2 4.4.4.4
Burada;
Router2 için DR 4.4.4.4'lü Interface'dir.
Router1 için BDR 1.1.1.1'li Interface'dir.


Authentication Password: Router oturum şifreleridir.
Stub Area Flag: Özel bir area olup her iki routerda da aynı olmalıdır.

2- Değişiklik varsa, yani ortama yeni bir router eklendiğinde veya bir router down olduğunda, Trigger Update ile LSA paketlerini neighbour (komşu) router'lara gönderir ki Neighbour (komşu) tablosunda, bir router'ın iletişim kurduğu tüm router'ların listesi bulunur. LSA paketini alan router, kendi LSA tablosunu günceller.


NOT: Aynı alandaki (area) tüm router'lar ortak veri tabanı olan LSDB’ye sahiptir.

3- Metrik hesaplaması, Cost Calculation'ı yeniden düzenler yani yol bilgisi ve mesafe tekrar hesaplanır.

4- Değişen Cost Calculation ile oluşturulmuş olan SPF (Shortest Path First) algoritması ile network (ağ) toplojisini günceller.

5- Network (ağ) üzerinde herhangi bir değişiklik yoksa, güncelleme yapılmaz ve network'te (ağda) dolalan tek trafik, Hello paketidir.

OSFP Yapılandırması

OSPF Konfigürasyonu Yazım Kuralı:

Router>enable Router#configure terminal
Router(config)#router ospf 1
Router(config-router)#network networkID WilcardMask areaNo

(routerın diğer router'lara bildireceği network. Bu kısıma, router'a bağlı olan tüm bacakların, yani network'lerin, IP Adres bilgileri tek tek girilmelidir.)

OSPF Konfigürasyonu

Area'lardaki Router sayısı arttıkça LSA paketi sayısı da aynı oranda artmaktadır. Dolayısıyla da oluşan LSDB boyutu büyür ve CPU yükü artar. Area'lar oluşturmak suretiyle bir değişikliğin sadece o area'daki Router'alara bildirilerek gereksiz network trafiğinin önününe geçilmiş olur. Birden fazla area'dan oluşturulan sisteme otonom sistem denir.

Bir otonom sistemde tüm area'lar backbone area (omurga alan) olan area0'a bağlı olmak zorundadır.

Area'lar arasındaki bağlantıyı ABR (Area Border Router-Alan Sınır Yönlendirici) router'lar sağlar. Aşağıdaki görselde R2 ve R3 router'ları ABR (Area Border Router) router'lardır.
OSFP Yapılandırması
OSFP Yapılandırması

AREA-0 Yapılandırması

AREA0-ROUTER1 konfigürasyonu

Router>enable
Router#configure terminal
Router(config)#hostname AREA0-ROUTER1
AREA0-ROUTER1(config)#interface gigabitEthernet 0/0
AREA0-ROUTER1(config-if)#ip address 10.10.10.1 255.255.255.0
AREA0-ROUTER1(config-if)#no shutdown
AREA0-ROUTER1(config-if)#exit
AREA0-ROUTER1(config)#interface serial 0/0/0
AREA0-ROUTER1(config-if)#ip address 87.87.87.2 255.255.255.0
AREA0-ROUTER1(config-if)#ip ospf priority 1
AREA0-ROUTER1(config-if)#clock rate 128000
AREA0-ROUTER1(config-if)#no shutdown
AREA0-ROUTER1(config-if)#exit
AREA0-ROUTER1(config)#interface serial 0/0/1
AREA0-ROUTER1(config-if)#ip address 88.88.88.1 255.255.255.0
AREA0-ROUTER1(config-if)#ip ospf priority 1
AREA0-ROUTER1(config-if)#clock rate 128000
AREA0-ROUTER1(config-if)#no shutdown
AREA0-ROUTER1(config-if)#exit
AREA0-ROUTER1(config)#do write
Building configuration...
[OK]
AREA0-ROUTER1(config)#end

OSFP Yapılandırması

AREA0-ROUTER1 hostname'li Router'ın kendisine bağlı network'lerin ve area bilgisinin tanımlanması.

AREA0-ROUTER1#configure terminal
AREA0-ROUTER1(config)#router ospf 1
AREA0-ROUTER1(config-router)#network 87.87.87.0 0.0.0.255 area 0
AREA0-ROUTER1(config-router)#network 88.88.88.0 0.0.0.255 area 0
AREA0-ROUTER1(config-router)#network 10.10.10.0 0.0.0.255 area 0
AREA0-ROUTER1(config-router)#do wr
Building configuration...
[OK]

OSFP Yapılandırması

AREA-1 Yapılandırması

ABR-Router1 konfigürasyonu

Router>enable
Router#configure terminal
Router(config)#hostname ABR-Router1
ABR-Router1(config)#interface serial 0/0/0
ABR-Router1(config-if)#ip address 87.87.87.1 255.255.255.0
ABR-Router1(config-if)#ip ospf priority 1
ABR-Router1(config-if)#no shutdown
ABR-Router1(config-if)#exit
ABR-Router1(config)#interface serial 0/0/1
ABR-Router1(config-if)#ip address 86.86.86.1 255.255.255.0
ABR-Router1(config-if)#ip ospf priority 1
ABR-Router1(config-if)#clock rate 128000
ABR-Router1(config-if)#no shutdown
ABR-Router1(config-if)#exit
ABR-Router1(config)#do write
Building configuration...
[OK]
ABR-Router1(config)#end

OSFP Yapılandırması

ABR-Router1 hostname'li Router'ın kendisine bağlı network'lerin ve area bilgisinin tanımlanması.

ABR-Router1#configure terminal
ABR-Router1(config)#router ospf 1
ABR-Router1(config-router)#network 87.87.87.0 0.0.0.255 area 0
ABR-Router1(config-router)#network 86.86.86.0 0.0.0.255 area 1
ABR-Router1(config-router)#do wr
Building configuration...
[OK]

OSFP Yapılandırması

AREA1-ROUTER1 konfigürasyonu

Router>enable
Router#configure terminal
Router(config)#hostname AREA1-ROUTER1
AREA1-ROUTER1(config)#interface gigabitEthernet 0/0
AREA1-ROUTER1(config-if)#ip address 10.10.20.1 255.255.255.0
AREA1-ROUTER1(config-if)#ip ospf priority 1
AREA1-ROUTER1(config-if)#no shutdown
AREA1-ROUTER1(config-if)#exit
AREA1-ROUTER1(config)#interface serial 0/0/0
AREA1-ROUTER1(config-if)#ip address 86.86.86.2 255.255.255.0
AREA1-ROUTER1(config-if)#no shutdown
AREA1-ROUTER1(config-if)#do write
Building configuration...
[OK]
AREA1-ROUTER1(config-if)#end

OSFP Yapılandırması

AREA1-ROUTER1 hostname'li Router'ın kendisine bağlı network'lerin ve area bilgisinin tanımlanması.

AREA1-ROUTER1#configure terminal
AREA1-ROUTER1(config)#router ospf 1
AREA1-ROUTER1(config-router)#network 86.86.86.0 0.0.0.255 area 1
AREA1-ROUTER1(config-router)#network 10.10.20.0 0.0.0.255 area 1
AREA1-ROUTER1(config-router)#do wr
Building configuration...
[OK]

OSFP Yapılandırması

AREA-2

ABR-Router2 konfigürasyonu

Router>enable
Router#configure terminal
Router(config)#hostname ABR-Router2
ABR-Router2(config)#interface serial 0/0/0
ABR-Router2(config-if)#ip address 88.88.88.2 255.255.255.0
ABR-Router2(config-if)#ip ospf priority 1
ABR-Router2(config-if)#no shutdown
ABR-Router2(config-if)#exit
ABR-Router2(config)#interface serial 0/0/1
ABR-Router2(config-if)#ip address 89.89.89.1 255.255.255.0
ABR-Router2(config-if)#ip ospf priority 1
ABR-Router2(config-if)#clock rate 128000
ABR-Router2(config-if)#exit
ABR-Router2(config)#do write
Building configuration...
[OK]
ABR-Router2(config)#end

OSFP Yapılandırması

ABR-Router2 hostname'li Router'ın kendisine bağlı network'lerin ve area bilgisinin tanımlanması.

ABR-Router2#configure terminal
ABR-Router2(config)#router ospf 1
ABR-Router2(config-router)#network 88.88.88.0 0.0.0.255 area 0
ABR-Router2(config-router)#network 89.89.89.0 0.0.0.255 area 2
ABR-Router2(config-router)#do wr
Building configuration...
[OK]

OSFP Yapılandırması

AREA2-ROUTER1 konfigürasyonu

Router>enable
Router#configure terminal
Router(config)#hostname AREA2-ROUTER1
AREA2-ROUTER1(config)#interface gigabitEthernet 0/0
AREA2-ROUTER1(config-if)#ip address 10.10.30.1 255.255.255.0
AREA2-ROUTER1(config-if)#no shutdown
AREA2-ROUTER1(config-if)#exit
AREA2-ROUTER1(config)#interface serial 0/0/0
AREA2-ROUTER1(config-if)#ip address 89.89.89.2 255.255.255.0
AREA2-ROUTER1(config-if)#ip ospf priority 1
AREA2-ROUTER1(config-if)#no shutdown
AREA2-ROUTER1(config-if)#do write
Building configuration...
[OK]
AREA2-ROUTER1(config-if)#end

OSFP Yapılandırması

AREA2-ROUTER1 hostname'li Router'ın kendisine bağlı network'lerin ve area bilgisinin tanımlanması.

AREA2-ROUTER1#configure terminal
AREA2-ROUTER1(config)#router ospf 1
AREA2-ROUTER1(config-router)#network 89.89.89.0 0.0.0.255 area 2
AREA2-ROUTER1(config-router)#network 10.10.30.0 0.0.0.255 area 2
AREA2-ROUTER1(config-router)#do wr
Building configuration...
[OK]

OSFP Yapılandırması

OSPF Konfigürasyon Sonrası Test Aşaması

OSPF yapılandırma işlemim tamamlandı. Sıra; yapılandırmamın başarılı bir şekilde oluşturulup, oluşturulmadığını test etmeye geldi. 
OSFP Yapılandırması

AREA1 network'ündeki A1PC1 hostname'li PC'den, AREA2 network'ündeki A2PC3 hostname'li PC'ye ICMP Request (ping) paketi yolluyorum.

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

OSFP Yapılandırması

ICMP Request (ping) paketini alan AREA2 network'ündeki A2PC3 hostname'li PC, aynı yolu izleyerek ICMP Reply (ping) paketi yolluyor ve yapılandırmamızın başarılı bir şekilde tamamladığını görebiliyorum.

OSFP Yapılandırması


Faydalı olması dileğiyle...
 


Beğendiğiniz içerikleri facebook, twitter, g+1 veya LinkedIn üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.


Her türlü görüş ve önerilerinizi aşağıdaki YORUM panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.

YAZAR HAKKINDA:

Microsoft Certified Trainer-MCT.
Microsoft Certified Solution Expert-MCSE: Cloud Platorm and Infrastructure.

Adım Fırat Boyan. Bilgi Teknolojileri Sistem ve Ağ Mühendisiyim. 1985 Alanya doğumluyum. 2008 yılından beri İstanbul'da yaşıyorum. 15 yıldır Bilişim Teknolojileri sektöründeyim.

2003 yılında lise eğitimimden sonra bir bilgisayar teknik servisinde önce stajyer, sonrasında ise teknik servis teknisyeni olarak başladığım bilişim sektörü çalışma hayatıma, üniversite eğitimimi tamamladıktan sonra, çeşitli şirketlerin bilgi işlem departmanlarında Sistem Destek Uzmanı, IT Uzmanı, IT Sistem Sorumlusu ve IT Sistem Yöneticisi olarak devam ettim ve çok çeşitli projelerde aktif rol alıp Sistem ve Network alanında ciddi deneyimler edinerek bilgime bilgi, tecrübeme tecrübe kattım.

JP. Morgan Chase Bank'ta Sistem Uzmanı ve Analisti olarak görev yapıyor, Türkiye’nin bilişim eğitimleri alanında hizmet veren Bilgi Tekolojileri Eğitim Merkezleri olan Bilge Adam’da MCT-Microsoft Certified Trainer (Microsoft Sertifikalı Eğitmen) ünvanı ile Sistem, Network ve Güvenlik eğitimleri veriyor, kurumsal firmalara Bilişim Teknolojileri Danışmanlık Hizmetleri sunuyorum.

Sertifikalarım:

MCT (Microsoft Certified Trainer)- 2016/2017 - 2017/2018 - 2018/2019
MCPS (Microsoft Certified Professional)
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2012
MCSE (Microsoft Certified Solutions Expert)- Server Infrastructure
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2017
MCSE (Microsoft Certified Solutions Expert)- Messaging
MCSE (Microsoft Certified Solutions Expert)- Productivity 2017
MS (Microsoft Specialist)- Designing and Deploying Microsoft Exchange Server 2016
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2016
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2018
MCSE (Microsoft Certified Solutions Expert)- Productivity 2018




comment YORUMLAR
Bu makaleye henüz yorum yapılmadı!
İlk yorum yapan sen ol.


Her türlü görüş ve önerilerinizi aşağıdaki yorum panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.


YORUM YAZ

   
  
(yorum onay bildirimi için gereklidir, yayınlanmaz.)
  750 Karakter yazabilirsiniz.
   
Güvenlik kodunu BÜYÜK harflerle giriniz.

* Yorumlar, onaylandıktan sonra yayınlanmaktadır.










BT EĞİTİM

Kurumsal eğitimler veren bir Microsoft Sertifikalı IT eğitmeniyim. IT Danışmanlık Hizmetleri verdiğim kurumlarda sürekli olarak, bilgi işlem personellerinin yaptığı işleri genelde ezbere ve neden yaptıklarını tam olarak kavrayamadan, bilmeden yaptıklarına şahit oldum. Böyle durumlarda da genelde firmalar, çalışanlarına IT eğitimleri aldırarak, daha profesyonel ve biliçli personeller istihdam etmektedirler. Sizler de kurumunuzda istihdam ettirdiğiniz bilgi işlem personellerinize IT Eğimleri aldırarak, kurumsal olarak yeni teknolojilere daha güçlü ve bilinçli geçişler yaparak ya da mevcut teknolojiler ile yapılandırılmış alt yapınızın bilgi işlem personelleriniz tarafından bilinçli ve profesyonel olarak ayakta tutmasını ve yürütmesini sağlayabilirsiniz.

Detaylar »





BT DANIŞMANLIK

Kendi bünyesinde IT departmanı isitihdam etmeyen ve bu hizmeti danışmanlık kapsamında outsource olarak alan firmalar, bilgisayar sistemlerinin bakımı ve onarımı için profesyonellerden bakım anlaşması kapsamında hizmet talep etmektedirler. Bilişim sektöründe danışmanlık önemli bir konudur. Bu nedenle, işinin ehli olmayan kişilere sisteminizi emanet edemezsiniz. Profesonel IT Uzmanı olarak; işletmelerin Kurumsal IT ihtiyaçlarına yönelik IT ekipmanlarının ve sistemlerinin kurulum,bakım ve konfigürasyonlarının yapılması hizmetlerini sunuyorum.

Detaylar »





İLETİŞİM

Taleplerinizi iletişim formu aracılığıyla direkt olarak bana iletebilirsiniz.
İletilerinize cevap verebilmem için mutlaka gerçeli bir e-posta adresi girin. Gönderdiğiniz iletiler en kısa sürede cevaplanacaktır. Girdiğiniz bilgiler asla üçüncü taraflarla paylaşılmaz. İletilerinizi iletişim formu aracılığı ile direkt olarak iletebileceğiniz gibi, kendi e-posta sunucunuzu kullanarak da mail adresime iletebilirsiniz.

İletişim Formu »