Fırat Boyan | MCT- Microsoft Certified Trainer.



Beğendiğiniz içerikleri sosyal medya üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.

category KATEGORİ: Routing-Switching
category Fırat Boyan category 08.06.2018 category 2

Inter Vlan Routing - Router On a Stick Nedir? Nasıl Yapılandırılır?


VLAN'lerden oluşan bir network'te her VLAN (sanal ağ), ayrı bir "broadcast domain" oluşturduğu için, farklı VLAN'ler ek yapılandırma yapılmadan birbirleri ile haberleşemezler. Farklı VLAN'lerin iletişim kurabilmeleri için router üzerinde yapılandırma yapılması gerekmektedir. Farklı VLAN'lerin router üzerinde tanımlanması işlemi, her VLAN için router'ın farklı bir Interfece'i kullanılarak yapılabileceği gibi, router'ın bir Interfece'inde Sub-Interface'ler oluşturarak da yapılabilir ki router gibi sınırlı sayıda Interface'in bulunduğu cihazlarda, her ne kadar ek modül takılabiliyor olsa da, bu da ek maliyet anlamına gelir, tek bir Interface üzerinde Sub-Interface'ler oluşturmak, maliyet açısından en mantıklısı olanı olacaktır. Teknoloji, bize bunu sağlıyorsa, neden kullanmayalım ki? smiley

Router'larda Sub-Interface'ler tanımlanarak yapılan yapılandırmalar, "Router On a Stick" ya da başka bir ifade ile "Inter Vlan Routing" olarak adlandırılır.

Inter Vlan Routing

Inter Vlan Routing

Inter Vlan Routing için Switch Yapılandırması

Yapılandırmamızı ilk önce ilgili switch üzerinde yapılandıracak, Vlan yapılandırma işlemini gerçekleştireceğiz. Bu yapılandırmada sırası ile;

1- VLAN Trunk Yapılandırma
2- VLAN Oluşturma, Vlan Yapılandırma
3- VLAN'leri Switch Port'lara Atama, Tanımlama


1- VLAN Trunk Yapılandırma
Yapılandırmamızın ilk adımı olarak, Switch port üzerindeki Vlan TRUNK Yapılandırması olacaktır. Vlan Trunk yapılandırması, Switch port'u üzerinden birden fazla Vlan'e ait data paketlerinin taşınması için gereklidir.

Biraz daha netleştirecek olursam; bir switch port'undan sadece bir vlan’a ait paketler geçebilir. Peki bu durumda farklı vlan’lara sahip iki switch’i birbirine bağladığımız zaman haberleşmelerini nasıl sağlayacağız?

İşte bu noktada yardımımıza trunk port yetişiyor. Yapımızdaki switch üzerinde 2 ayrı (Ör. SWITCH01 üzerinde Vlan 10 ve Vlan 20) Vlan yapılandırması var. Bu iki ayrı Vlan'e ait bilgilerin iletilebilmesi için, Switch port üzerinde TRUNK Yapılandırması yapılmalıdır.

Switch Üzerinde TRUNK Yapılandırma:
Switch üzerindeki gigabitEthernet 0/1 port'una girip, Switch Mode Trunk olarak yapılandırarak, Gi0/1 port'undan farklı Vlan'lerin geçeceği bilgisini veriyorum.

SWITCH01(config)#int gigabitEthernet 0/1
SWITCH01(config-if)#switchport mode trunk


Inter Vlan Routing

2- VLAN Oluşturma, Vlan Yapılandırma
Switch port üzerinde TRUNK yapılandırma işemini tamamladıktan sonra, Gerekli olan VLAN'leri oluşturağız.

Switch üzerinde Vlan 10 ve Vlan 20 olarak toplamda 2 adet Vlan oluşturacağım.

SWITCH01#configure terminal
SWITCH01(config)#vlan 10
SWITCH01(config-vlan)#name IT

SWITCH01(config-vlan)#exit
SWITCH01(config)#vlan 20
SWITCH01(config-vlan)#name IK


Inter Vlan Routing

3- VLAN'leri Switch Port'lara Atama, Tanımlama
VLAN'lerimizi oluşturduktan sonra, bu Vlan bilgilerini Switch Port'lara atayacağız yani tanımlayacağız.

IT ve IK olmak üzere iki farklı departmanımız bulunuyor;

Bu departmana ait VLAN bilgileri IT için Vlan 10, IK için ise Vlan 20 şeklindedir.

IT için Vlan 10 bilgisini; fastEthernet 0/1 ve fastEthernet 0/2 ve fastEthernet 0/3 olan port'lara atayacağız.
Daha sonra;
IK için Vlan 20, bilgisini; fastEthernet 0/4 ve fastEthernet 0/5 ve fastEthernet 0/6 olan port'lara atayacağız.

SWITCH01>enable
SWITCH01#configure terminal
SWITCH01(config)#interface range fastEthernet 0/1-3
SWITCH01(config-if-range)#switchport mode access
SWITCH01(config-if-range)#switchport access Vlan 10

SWITCH01(config-if-range)#exit
SWITCH01(config)#do wr
Building configuration...
[OK]
SWITCH01(config)#interface range fastEthernet 0/4-6
SWITCH01(config-if-range)#switchport mode access
SWITCH01(config-if-range)#switchport access vlan 20

SWITCH01(config-if-range)#exit
SWITCH01(config)#do wr
Building configuration...
[OK]
SWITCH01(config)#

Inter Vlan Routing

show vlan komutu ile de, oluşturmuş oluşturduğumuz VLAN'leri görüntüleyebiliriz.

Inter Vlan Routing

Inter Vlan Routing (Router On a Stick) için Router Yapılandırması

Switch üzerindeki yapılandırmalarımızı tamamladıktan sonra sıra, Router üzerindeki yapılandırmaya geldi.

Burada yapacağımız işlem, tek hat yani tek Interface üzerinden birden fazla VLAN bilgisini geçirerek, VLAN'ler arası yönlendirme (InterVlan Routing - router on a stick) işlemini gerçekleştirmek olacaktır.

İlk olarak yapacağım işlem, router'ın, switch'e bağlanan gigabitEthernet 0/1 port'una girerek port'u açmak olacak. Ancak, port'a herhangi bir IP adresi ataması gerçekleştirMEyeceğim. Çünkü port üzerinde Sub-Interface'ler oluşturarak, herbir VLAN'in default gateway'i olmasını sağlayacağım. IP adresi atama işlemlerini bu Sub-Interface'ler üzerinde oluşturacağım.

ROUTER01>enable
ROUTER01#configure terminal
ROUTER01(config)#interface gigabitEthernet 0/1
ROUTER01(config-if)#no ip address
ROUTER01(config-if)#no shutdown


Inter Vlan Routing

Sub-Interface Yapılandırma ve VLAN encapsulation (kapsüllenme)

1- Sub-Interface Yapılandırma
Sub-Interface, router'ımın switch'e bakan ayağında birden fazla VLAN'e ait data frame'lerini tek hat üzerinden geçirmek için tek hat üzerine birden fazla yol açma işlemidir.

Sub-Interface oluştururken dikkat edilcek nokta, Interface ID'sinden sonra ilgili VLAN numarasını .(nokta)'dan sonra belirtmek olacaktır. Bunu yapmazsanız, o port'a tek bir IP ataması yapmış olursunuz ki bu da, diğer VLAN'ler için IP ataması yapamayacağınız anlamına gelir.

Örneğin: interface gigabitEthernet 0/1.10

2- VLAN encapsulation (kapsüllenme)
Doq1q (802.1Q), IEEE tarafından geliştirilmiş bir VLAN encapsulation (kapsüllenme) standartıdır. Ethernet data paketlerinin içerisine yerleştirdiği bit'ler sayesinde, VLAN kimliğinin ne olduğunu belirler. Yani örneğin, Gi0/1 portundan geçecek Vlan 10, Vlan 20 ve diğer Vlan'lerin bilgilerini etiketlemeye yarayan bir protokoldür.

802.1Q standardı; VLAN kullanımında ortaya çıkan, büyük ağları daha küçük ve yönetilebilir parçalara bölme ihtiyacını karşılamak için geliştirilmiştir. Cisco'nun geliştirdiği ISL standardından farklı olarak, farklı markalı cihazlarla uyumlu çalışabilmesi 802.1Q'yu oldukça popüler bir hale getirmiştir. Ayrıca 802.1Q protokolü, 30 byte'lik bir etiketleme yapan ISL'ye göre 26 byte daha küçüktür. Yani 802.1Q, hedef MAC adresi ile ethernet frame'i arasına 4 byte'lık bir bir veri eklenmektedir. Böylece, boyuttaki küçülmenin 802.1Q'yu ISL'ye göre daha hızlı hale getirdiği söylenebilir.

Kapsülleme yaparken dikkat edilecek nokta, kapsüllemenin hangi VLAN ID'ye göre etiketleneceğini dot1Q(802.1Q)  kapsülleme standardından sonra bir boşluk bırakıp, ilgili Vlan ID'sini belirtmek olacaktır.

Örneğin: encapsulation dot1Q 10

gabitEthernet 0/1 üzerinde VLAN 10 için IP ataması:
ROUTER01(config)#interface gigabitEthernet 0/1.10
ROUTER01(config-subif)#encapsulation dot1Q 10
ROUTER01(config-subif)#ip address 10.10.1.1 255.255.255.0

ROUTER01(config-subif)#exit

gabitEthernet 0/1 üzerinde VLAN 20 için IP ataması:
ROUTER01(config)#interface gigabitEthernet 0/1.20
ROUTER01(config-subif)#encapsulation dot1Q 20
ROUTER01(config-subif)#ip address 10.10.2.1 255.255.255.0

ROUTER01(config-subif)#exit

Inter Vlan Routing

Buraya kadar; Switch üzerinde gerekli VLAN'ler oluşturdu. Daha sonrasında da Router üzerinde kapsülleme ve VLAN IP adresi (default gateway) atama işlemleri yapılarak Inter Vlan Routing için tüm işlemlerimizi yapılandırdık. Şuan hem VLAN 10 hem de VLAN 20 network'lerine ait client'lar birbirleri ile haberleşebilir durumdadırlar.

Yapılandırma Sonrası Test İşlemleri
Yapılandımamızın sağlıklı bir şekilde çalışıp çalışmadığını kontrol etmek amacıyla VLAN 10 network'ündeki IP adresi 10.10.1.30 olan bir client PC'nin, VLAN 20 network'ündeki IP adresi 10.10.2.10 olan diğer bir client PC'ye bir data paketi yollamasını sağlayacağız.

1- Data paketi IP adresi 10.10.1.30 olan PC2 isimli client PC'de.

Inter Vlan Routing

Data paketi yola çıktı. VLAN 10'a bağlı olan FastEthernet 0/3 port'undan switch'e iletildi. 

Inter Vlan Routing

Switch, bu data paketini GigabitEthernet 0/1 port'undan router'a yolladı.


Inter Vlan Routing

802.1Q (Doq1q) standardı ile MAC adresi ile ethernet frame'i arasına 4 byte'lık bir bir veri ekleyerek VLAN kimliğinin ne olduğunu belirledi ve Router da bu data paketini kendi üzerindeki GigabitEthernet 0/1 port'u üzerinden VLAN 20 network'ündeki hedefe ulaştırmak için switch'e ulaştırdı.

Inter Vlan Routing

Switch, router'dan gelen bu data peketini VLAN 20 network'ündeki IP adresi 10.10.2.10 olan PC3 isimli client PC'ye ulaştırmak için, PC3'ün bağlı olduğu FastEthernet 0/4 portundan iletimini tamamladı.

Inter Vlan Routing

Yukarıda bahsedilelin tam tersi yolunda iletilen request, reply edilerek gönderim işleminin tamamlandığı bilgisini almış olduk.


Inter Vlan Routing

Aşağıdaki CMD ekranında da IP adresi 10.10.1.30 olan PC2 isimli client PC'den, IP adresi 10.10.2.10 olan PC3 isimli client pc'ye ping atma işleminin de başarılı bir şekilde gerçekleştiğini görebiliyoruz.

Inter Vlan Routing

Faydalı olması dileğiyle...

 


Beğendiğiniz içerikleri facebook, twitter, g+1 veya LinkedIn üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.


Her türlü görüş ve önerilerinizi aşağıdaki YORUM panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.

YAZAR HAKKINDA:

Microsoft Certified Trainer-MCT.
Microsoft Certified Solution Expert-MCSE: Cloud Platorm and Infrastructure.

Adım Fırat Boyan. Bilgi Teknolojileri Sistem ve Ağ Mühendisiyim. 1985 Alanya doğumluyum. 2008 yılından beri İstanbul'da yaşıyorum. 15 yıldır Bilişim Teknolojileri sektöründeyim.

2003 yılında lise eğitimimden sonra bir bilgisayar teknik servisinde önce stajyer, sonrasında ise teknik servis teknisyeni olarak başladığım bilişim sektörü çalışma hayatıma, üniversite eğitimimi tamamladıktan sonra, çeşitli şirketlerin bilgi işlem departmanlarında Sistem Destek Uzmanı, IT Uzmanı, IT Sistem Sorumlusu ve IT Sistem Yöneticisi olarak devam ettim ve çok çeşitli projelerde aktif rol alıp Sistem ve Network alanında ciddi deneyimler edinerek bilgime bilgi, tecrübeme tecrübe kattım.

JP. Morgan Chase Bank'ta Sistem Uzmanı ve Analisti olarak görev yapıyor, Türkiye’nin bilişim eğitimleri alanında hizmet veren Bilgi Tekolojileri Eğitim Merkezleri olan Bilge Adam’da MCT-Microsoft Certified Trainer (Microsoft Sertifikalı Eğitmen) ünvanı ile Sistem, Network ve Güvenlik eğitimleri veriyor, kurumsal firmalara Bilişim Teknolojileri Danışmanlık Hizmetleri sunuyorum.

Sertifikalarım:

MCT (Microsoft Certified Trainer)- 2016/2017 - 2017/2018 - 2018/2019
MCPS (Microsoft Certified Professional)
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2012
MCSE (Microsoft Certified Solutions Expert)- Server Infrastructure
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2017
MCSE (Microsoft Certified Solutions Expert)- Messaging
MCSE (Microsoft Certified Solutions Expert)- Productivity 2017
MS (Microsoft Specialist)- Designing and Deploying Microsoft Exchange Server 2016
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2016
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2018
MCSE (Microsoft Certified Solutions Expert)- Productivity 2018




comment YORUMLAR
Bu makaleye 2 yorum yapıldı.

Her türlü görüş ve önerilerinizi aşağıdaki yorum panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.


YORUM YAZ

   
  
(yorum onay bildirimi için gereklidir, yayınlanmaz.)
  750 Karakter yazabilirsiniz.
   
Güvenlik kodunu BÜYÜK harflerle giriniz.

* Yorumlar, onaylandıktan sonra yayınlanmaktadır.




YAPILAN YORUMLAR


08-06-2018


Mehmet Akif Öksüz

Ellerine emeklerine sağlık hocam. Yine eksiksiz, anlaşılabilir, ayrıntılı bir yazı olmuş.


09-06-2018


Fırat Boyan

Teşekkürler Mehmet kardeşim.






BT EĞİTİM

Kurumsal eğitimler veren bir Microsoft Sertifikalı IT eğitmeniyim. IT Danışmanlık Hizmetleri verdiğim kurumlarda sürekli olarak, bilgi işlem personellerinin yaptığı işleri genelde ezbere ve neden yaptıklarını tam olarak kavrayamadan, bilmeden yaptıklarına şahit oldum. Böyle durumlarda da genelde firmalar, çalışanlarına IT eğitimleri aldırarak, daha profesyonel ve biliçli personeller istihdam etmektedirler. Sizler de kurumunuzda istihdam ettirdiğiniz bilgi işlem personellerinize IT Eğimleri aldırarak, kurumsal olarak yeni teknolojilere daha güçlü ve bilinçli geçişler yaparak ya da mevcut teknolojiler ile yapılandırılmış alt yapınızın bilgi işlem personelleriniz tarafından bilinçli ve profesyonel olarak ayakta tutmasını ve yürütmesini sağlayabilirsiniz.

Detaylar »





BT DANIŞMANLIK

Kendi bünyesinde IT departmanı isitihdam etmeyen ve bu hizmeti danışmanlık kapsamında outsource olarak alan firmalar, bilgisayar sistemlerinin bakımı ve onarımı için profesyonellerden bakım anlaşması kapsamında hizmet talep etmektedirler. Bilişim sektöründe danışmanlık önemli bir konudur. Bu nedenle, işinin ehli olmayan kişilere sisteminizi emanet edemezsiniz. Profesonel IT Uzmanı olarak; işletmelerin Kurumsal IT ihtiyaçlarına yönelik IT ekipmanlarının ve sistemlerinin kurulum,bakım ve konfigürasyonlarının yapılması hizmetlerini sunuyorum.

Detaylar »





İLETİŞİM

Taleplerinizi iletişim formu aracılığıyla direkt olarak bana iletebilirsiniz.
İletilerinize cevap verebilmem için mutlaka gerçeli bir e-posta adresi girin. Gönderdiğiniz iletiler en kısa sürede cevaplanacaktır. Girdiğiniz bilgiler asla üçüncü taraflarla paylaşılmaz. İletilerinizi iletişim formu aracılığı ile direkt olarak iletebileceğiniz gibi, kendi e-posta sunucunuzu kullanarak da mail adresime iletebilirsiniz.

İletişim Formu »