Fırat Boyan | MCT- Microsoft Certified Trainer.



Beğendiğiniz içerikleri sosyal medya üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.

category KATEGORİ: Routing-Switching
category Fırat Boyan category 05.12.2016 category 14

Vlan Nedir? Vlan Nasıl, Yapılandırılır? Adım adım VLAN Oluşturma


Bu makalemde VLAN (Virtual Local Area Network) nedir, nasıl yapılandırılır? sorunusuna açıklık getirip, Vlan yapılandırma, oluşturma konusundan bahsediyor olacağım.

Vlan Nedir?

Sanal Yerel Alan Ağı (VLAN), bir LAN (Local Area Network) network üzerindeki ağ kullanıcılarının ve kaynakların mantıksal olarak gruplandırılması ve switch üzerinde port'lara atanmasıyla yapılır.

VLAN kullanılmasıyla her VLAN,sadece kendi broadcast'ini alacağından, broadcast trafiği azaltılarak bandwith (bant genişliği) artırılmış olur. Başka bir ifade ile VLAN; birden fazla switch barındıran yapılardaki network trafiğinde data paketleri, ARP protokolü ile paketi aldığı port haricindeki tüm Switch port'larına dağıtacağı için, tüm network'ü dolaşmış olacak. Bu da gereksiz bir boradcast trafiği oluşmasına sebep olacak ve bant genişliğinin gereksiz yere kullanılmasına sebep olacaktır.

Aslında bunu sadece broadcast ve bandwidth (bant genişliği) kapsamında değil, güvenlik kapsamında da ele alıp düşünmek gerekmektedir. Şirketimize misafir olarak gelen, ve sistemimizde tanımlı olmayan birisini sistem network'ümüze dahil etmek, çok da akıllıca ve istenen bir şey olmayacaktır. Bu nedenle, sistemden izole edilmiş bir network üzerinden misafirimizi internet ortamına çıkartmak, güvenlik açısından atılabilecek en önemli adımlardan birisi olacaktır ki bunu da network'ümüzü segmentlere bölümleyerek, yani VLAN'lar oluşturarak yapabiliriz.

Sistemimiz üzerinde VLAN'lar oluşturarak network'ümüzü segmentlere bölümlemek, olası network problemlerini tanılama ve çözüme kavuşturmada bize kolaylık sağlayacaktır.

VLAN Türleri Nelerdir?

Veri VLAN'ı (Data VLAN)
Veri VLAN'ı özelleşmemiş standart trafiği taşımak üzere yapılandırılmış VLAN'dır. Kullanıcı kaynaklı İnternet trafiği buna örnek olarak gösterilebilir. Ayrıca bir VLAN aynı anda ses ya da video temelli trafik de taşıyabilir. Veri VLAN'ının bir diğer adı da Kullanıcı VLAN'ıdır (User VLAN).

Varsayılan VLAN (Default VLAN)
Switch'teki bütün port'lar, switch başlatıldığında otomatik olarak varsayılan VLAN'a dahil olurlar. Cisco cihazlar için Varsayılan VLAN "VLAN 1" dir. Switch port'larının Default VLAN'a bağlı olması, bu port'ları aynı broadcast domain'e dahil eder. Bu durum switch'lere bağlanan bütün cihazların birbirleriyle iletişim kurmasına olanak sağlar. 

VLAN 1, yeniden adlandırılamaması ve silinememesi dışında diğer VLAN'larla aynı özelliklere sahiptir.

Yerel VLAN (Native VLAN)
Yerel VLAN "Trunk" bağlantı noktasına atanmış VLAN'dır. Bir "Trunk" bağlantı noktası herhangi bir VLAN etiketi olmayan trafiği (untagged vlan traffic) olduğu gibi, çok sayıda VLAN tarafından oluşturulan trafiği de (tagged vlan traffic) destekler. "Trunk" bağlantı noktası herhangi bir VLAN'dan gelmeyen trafiği Yerel VLAN'a yönlendirir. Bir cihaz tarafından oluşturulan ve herhangi bir VLAN'dan gelmeyen trafik switch'in Yerel VLAN olarak yapılandırılmış olan vlan üzerinden iletilir.

Yönetim VLAN'ı (Management VLAN)
Yönetim VLAN'ı, switch'i yönetmek üzere yapılandırılmış herhangi bir VLAN olabilir. Eğer Yönetim VLAN'ı olarak özel bir VLAN yapılandırılMAmışsa, "VLAN 1" Yönetim VLAN'ı olarak hizmet verir. Yönetim VLAN'ına bir IP adresi ve subnet mask (alt ağ maskesi)  atandığında bu switch'e HTTP, Telnet, SSH ya da SNMP gibi yollarla bağlanılabilir.

Ek olarak belirtmek isterim ki; Cisco cihazlarda "VLAN 1" Varsayılan VLAN (Default Vlan)  olduğundan, Yönetim VLAN'ı ile Varsayılan VLAN'ı ayırmak güvenlik açısından tercih edilir.


Ses VLAN'ı (Voice VLAN)
Ses VLAN'ı, üzerinden sadece ses trafiğinin geçirilmesi yönünde yapılandırılan VLAN'dir. Ses iletimi, kişiler ve kurumlar için çok önemli olduğu için, Ses VLAN'ı sıklıkla kullanılmaktadır. Ses VLAN'inde ses iletimi için IP telefonu kullanılır.
Switch üzerindeki port'a Ses VLAN'ı yapılandırabilmek için öncelikle ses ve veri için iki ayrı VLAN yapılandırılması gerekir. Bir IP telefon, Switch'in ilgili bağlantı noktasına ilk defa bağlandığında, switch'in ilgili port'una IP telefona daha önceden yapılandırılmış VLAN'ın adını ve konfigürasyon bilgisini yollar. IP telefon da bu bilgileri aldıktan sonra, voice frame'lerini etiketleyerek tüm ses trafiğini Voice VLAN'ı üzerinden gönderir.

Vlan YapılandırılMAmış bir Network Ortamında Network Trafiği

Mantığın daha net anlaşılabilmesi için, VLAN oluşturulMAmış bir ağ üzerindeki data paketlerinin, tüm sisteme nasıl dağıldığına bir göz atalım:

3. Katta bulunan PC41 numaralı bilgisayardan, 1. kattaki PC9 numaralı bilgisayara bir data paketi yolluyorum.

Paketlerin rahatlıkla izlenebilmesi için, ARP protokolünü de devreye aldım. Bu iki bilgisayar, ilk kez haberleşecekleri için, PC41'den çıkan data paketi, tüm network'ü dolacaşacak, yani bir broadcast oluşturacaktır.

vlan yapılandırma, vlan konfigürasyonu

Aşağıda görüldüğü gibi; PC41'den çıkan data paketi, ARP Request içindeki Destination Mac Address bilgisi FF-FF-FF- FF-FF-FF (broadcast mac adresi) olduğu için, ilk önce 3. kataki tüm bilgisayarlara ulaştırıldı.

İlgili data paketi, ARP Request ile gelen data paketindeki Destination IP Address kendilerine ait olMAdığı için, tüm bilgisayarlar data paketini reddetti.


vlan yapılandırma, vlan konfigürasyonu

Aynı data paketi, ARP Request içindeki Destination Mac Address bilgisi FF-FF-FF- FF-FF-FF (broadcast mac adresi) olduğu için, 2. kataki tüm bilgisayarlara da ulaştırıldı.

İlgili data paketi, ARP Request ile gelen data paketindeki Destination IP Address kendilerine ait olMAdığı için, tüm bilgisayarlar data paketini reddetti.


vlan yapılandırma, vlan konfigürasyonu

Aynı data paketi, ARP Request içindeki Destination Mac Address bilgisi FF-FF-FF- FF-FF-FF (broadcast mac adresi) olduğu için, 1. kattaki tüm bilgisayarlara ulaştırıldı.

İlgili data paketi, ARP Request ile gelen data paketindeki Destination IP Address kendilerine ait olmadığı için, PC9 hariç, tüm bilgisayarlar data paketini reddetti.

PC9, ARP Request ile gelen data paketindeki Destination IP Address kendine ait olduğu için data paketini aldı.

vlan yapılandırma, vlan konfigürasyonu

İşte bu örnekte görüldüğü gibi, Vlan ile segmentlere bölünmemiş bir network ortamında data paketleri, bu şekilde ilk data paketi gönderiminde (daha önce hiç haberleşmemiş bilgisayarlar için) broadcast ile tüm network'e yayılmakta ve gereksiz yere bir trafik oluşmaktadır. Bu gereksiz broadcast'i önlemenin yolu da, Network'leri Vlan'ler ile segmentlere ayırmaktan geçmektedir.

Cisco Switch ile Vlan Nasıl Yapılandırılır?

Vlan YapılandırılMAmış bir Network Ortamında Network Trafiğini izledikten sonra, VLAN yapılandırma işlemimize geçebiliriz. Bu kısımda, adım adım Cisco Switch Vlan Yapılandırma işlemlerimize başlıyor olacağız. Vlan yapılandırma işlemlerimiz bittikten sonra, bu sefer de, Vlan Yapılandırılmış bir Network Ortamında Network Trafiğini izleyeceğiz.

Yapım şu şekilde olacak:

* 6 VLAN.
Vlan 10,Vlan 20,Vlan 30,Vlan 40,Vlan 50,Vlan 60
* 60 adet PC.
* 3 adet Layer-2 Cisco Switch (24 Port).
* 1 adet Layer-3 Cisco (backbone, omurga) Switch.
* 1 adet DHCP Server.


Ortamımızda 3(üç) adet Layer-2 Cisco Switch ve 1(bir) adet de Layer-3 Cisco Switch bulunmaktadır. Vlan yapılandırmalarımızı Layer-3 backbone yani omurga Switch üzerinden yapılandırarak, yine buradan tüm Layer-2 Switch'lerin üzerine Vlan yapılandırmalarını dağıtacağız. Ortamınızda birden fazla switch bulunuyorsa, tüm switch'leri tek tek dolaşıp, hepsinde Vlan yapılandırmak için zaman harcamak gereksizdir.

Layer-3 Switch'in bize sunduğu avantajlardan birisi de, ayrı Vlan grupları arasında bir router'a ihtiyaç duymadan IP ROUTING oluşturup, Vlan'lar arası iletişimi sağlayabilmesidir.

vlan yapılandırma, vlan konfigürasyonu

VLAN TRUNK YAPILANDIRMA

Yapılandırmamızın ilk adımı olarak, Switch'ler arasındaki Vlan TRUNK Yapılandırması olacaktır. Vlan Trunk yapılandırması, Switch'lerin üzerinden birden fazla Vlan'e ait data paketlerinin taşınması için gereklidir.

Biraz daha netleştirecek olursam; bir switch port'undan sadece bir vlan’a ait paketler geçebilir. Peki bu durumda farklı vlan’lara sahip iki switch’i birbirine bağladığımız zaman haberleşmelerini nasıl sağlayacağız?

İşte bu noktada yardımımıza vlan trunk port yetişiyor. Yapımızda her bir switch üzerinde 2 aynı Vlan yapılandırması var (Ör. KAT1-SWITCH üzerinde Vlan 50 ve Vlan 60). Bu iki ayrı Vlan'e ait bilgilerin ortamdaki diğer switch'lere de iletilebilmesi için, Switch'ler arası VLAN TRUNK Yapılandırması yapılmalıdır.

Trunk yapılandırması, Switch'lerin birbirlerine bağlanan portlarında yapılandırılır.

Vlan Switch port
Vlan Switch port

Backbone Switch Üzerinde VLAN TRUNK Yapılandırma:

BACKBONE-SWITCH(config)#int gigabitEthernet 0/1
BACKBONE-SWITCH(config-if)#switchport trunk encapsulation dot1q
BACKBONE-SWITCH(config-if)#switch mode trunk

Komutları açacak olursak;

Backbone switch üzerindeki gigabitEthernet 0/1 portuna giriyorum.
BACKBONE-SWITCH(config)#int gigabitEthernet 0/1

Gi0/1 portuna Dot1q (802.1Q) protokolünü tanımlıyorum.
BACKBONE-SWITCH(config-if)#switchport trunk encapsulation dot1q

802.1Q (dot1q) ve ISL

802.1Q (dot1Q)
Doq1q (802.1Q), IEEE tarafından geliştirilmiş bir VLAN encapsulation (kapsüllenme) standartıdır. Ethernet data paketlerinin içerisine yerleştirdiği bit'ler sayesinde, VLAN kimliğinin ne olduğunu belirler. Yani örneğin, Gi0/1 portundan geçecek Vlan 10 bilgisini, Vlan 20 ve diğer Vlan'lerin bilgilerini etiletmeye yarayan bir protokoldür.

802.1Q standardı; VLAN kullanımında ortaya çıkan, büyük ağları daha küçük ve yönetilebilir parçalara bölme ihtiyacını karşılamak için geliştirilmiştir.

ISL (Inter Switch Link)
Cisco'nun geliştirdiği ISL (Inter Switch Link) standardından farklı olarak, farklı markalı cihazlarla uyumlu çalışabilmesi 802.1Q'yu oldukça popüler bir hale getirmiştir.

Ayrıca
802.1Q protokolü, 30 byte'lik bir etiketleme yapan ISL'ye göre 26 byte daha küçüktür. Yani 802.1Q, hedef MAC adresi ile ethernet frame'i arasına 4 byte'lık bir bir veri eklenmektedir. Böylece, boyuttaki küçülmenin 802.1Q'yu ISL'ye göre daha hızlı hale getirdiği söylenebilir.

Switch Mode Trunk olarak yapılandırarak, Gi0/1 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
BACKBONE-SWITCH(config-if)#switch mode trunk

vlan yapılandırma, vlan konfigürasyonu

show interfaces trunk komutu ile portlar üzerindeki VLAN TRUNK yapılandırmasını görüntülüyorum.
BACKBONE-SWITCH>show interfaces trunk

vlan yapılandırma, vlan konfigürasyonu

KAT3 Switch Üzerinde VLAN TRUNK Yapılandırma:

KAT3 switch üzerindeki sırası ile gigabitEthernet 0/1 ve gigabitEthernet 0/2 portlarına gireceğim.

KAT3-SWITCH(config)#interface gigabitEthernet 0/1
KAT3-SWITCH(config-if)#switchport mode trunk
KAT3-SWITCH(config)#interface gigabitEthernet 0/2
KAT3-SWITCH(config-if)#switchport mode trunk

Switch üzerinde gigabitEthernet 0/1 portuna giriyorum.
KAT3-SWITCH(config)#interface gigabitEthernet 0/1

Switch Mode Trunk olarak yapılandırarak, Gi0/1 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
KAT3-SWITCH(config-if)#switchport mode trunk
KAT3-SWITCH(config-if)#exit


Switch üzerinde gigabitEthernet 0/2 portuna giriyorum.
KAT3-SWITCH(config)#interface gigabitEthernet 0/2

Switch Mode Trunk olarak yapılandırarak, Gi0/2 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
KAT3-SWITCH(config-if)#switchport mode trunk

vlan yapılandırma, vlan konfigürasyonu

show interfaces trunk komutu ile portlar üzerindeki VLAN TRUNK yapılandırmasını görüntülüyorum.
KAT3-SWITCH>show interfaces trunk

vlan yapılandırma, vlan konfigürasyonu

KAT2 Switch Üzerinde VLAN TRUNK Yapılandırma:

KAT2 switch üzerindeki sırası ile gigabitEthernet 0/1 ve gigabitEthernet 0/2 portlarına gireceğim.

KAT2-SWITCH(config)#interface gigabitEthernet 0/1
KAT2-SWITCH(config-if)#switchport mode trunk
KAT2-SWITCH(config)#interface gigabitEthernet 0/2
KAT2-SWITCH(config-if)#switchport mode trunk

Switch üzerinde gigabitEthernet 0/1 portuna giriyorum.
KAT2-SWITCH(config)#interface gigabitEthernet 0/1

Switch Mode Trunk olarak yapılandırarak, Gi0/1 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
KAT2-SWITCH(config-if)#switchport mode trunk
KAT2-SWITCH(config-if)#exit


Switch üzerinde gigabitEthernet 0/2 portuna giriyorum.
KAT2-SWITCH(config)#interface gigabitEthernet 0/2

Switch Mode Trunk olarak yapılandırarak, Gi0/2 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
KAT2-SWITCH(config-if)#switchport mode trunk

vlan yapılandırma, vlan konfigürasyonu

show interfaces trunk komutu ile portlar üzerindeki VLAN TRUNK yapılandırmasını görüntülüyorum.
KAT2-SWITCH>show interfaces trunk

vlan yapılandırma, vlan konfigürasyonu

KAT1 Switch Üzerinde VLAN TRUNK Yapılandırma:

KAT1 switch üzerindeki gigabitEthernet 0/1 port'una gireceğim.

KAT1-SWITCH(config)#interface gigabitEthernet 0/1
KAT1-SWITCH(config-if)#switchport mode trunk
KAT1-SWITCH(config)#interface gigabitEthernet 0/2
KAT1-SWITCH(config-if)#switchport mode trunk

Switch üzerinde gigabitEthernet 0/1 portuna giriyorum.
KAT1-SWITCH(config)#interface gigabitEthernet 0/1

Switch Mode Trunk olarak yapılandırarak, Gi0/1 portundan farklı Vlan'lerin geçeceği bilgisini veriyorum.
KAT1-SWITCH(config-if)#switchport mode trunk
KAT1-SWITCH(config-if)#exit


vlan yapılandırma, vlan konfigürasyonu

show interfaces trunk komutu ile portlar üzerindeki VLAN TRUNK yapılandırmasını görüntülüyorum.
KAT1-SWITCH>show interfaces trunk

VLAN OLUŞTURMA, VLAN YAPILANDIRMA

Switch port'larımız üzerinde TRUNK yapılandırmalarını tamamladıktan sonra, BackBone Switch'de VLAN oluşturağız. Vlan oluşturma işlemlerini sadece Layer3 BackBone Switch'de yapacağım. Bu sayede bir sonraki adım olaran VTP(Virtual LAN Trunking Protocol) yapılandırmasında, bu oluşturacağım Vlan'lerin diğer Switch'lere de tanımlanmasını sağlayarak, yapımdaki her Switch'i tek tek gerezek Vlan oluşturma zahmetine girmiş olmayacağım.

BackBone Switch üzerinde Vlan 10,Vlan 20,Vlan 30,Vlan 40,Vlan 50 ve Vlan 60 olarak toplamda 6 adet Vlan oluşturacağım.

BACKBONE-SWITCH#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#vlan 10
BACKBONE-SWITCH(config-vlan)#name IT

BACKBONE-SWITCH(config-vlan)#exit
BACKBONE-SWITCH(config)#vlan 20
BACKBONE-SWITCH(config-vlan)#name IK

BACKBONE-SWITCH(config-vlan)#exit
BACKBONE-SWITCH(config)#vlan 30
BACKBONE-SWITCH(config-vlan)#name ARGE

BACKBONE-SWITCH(config-vlan)#exit
BACKBONE-SWITCH(config)#vlan 40
BACKBONE-SWITCH(config-vlan)#name MUHENDISLIK

BACKBONE-SWITCH(config-vlan)#exit
BACKBONE-SWITCH(config)#vlan 50
BACKBONE-SWITCH(config-vlan)#name FINANS

BACKBONE-SWITCH(config-vlan)#exit
BACKBONE-SWITCH(config)#vlan 60
BACKBONE-SWITCH(config-vlan)#name YONETIM

BACKBONE-SWITCH(config-vlan)#exit

vlan yapılandırma, vlan konfigürasyonu

show vlan komutu ile de, oluşturmuş olduğumuz VLAN'leri görüntüleyebiliriz.

vlan yapılandırma, vlan konfigürasyonu

VTP (Virtual LAN Trunking Protocol) YAPILANDIRMA

Öncelikle VTP (Virtual LAN Trunking Protocol) yapısından biraz bahsetmek istiyorum;

VTP (Virtual LAN Trunking Protocol - Sanal Yerel Ağ Aktarım Protokolü), çok fazla sayıda switch bulunan ağlarda, protokolün adından da anlaşılabileceği gibi, "trunk" portlar (bağlantı noktası) sayesinde, VLAN (Virtual Local Area Network- Sanal Yerel Ağ)'ları diğer switch'lere taşımayı sağlar. VTP bir anlamda, VLAN Domain (VLAN Etki Alanı) olarak da adlandırabilir. VLAN'ler üzerinde VTP ağ yöneticisine ekleme, silme, ad ekleme, değiştirme gibi çeşitli yetkiler verilir ve VTP sayesinde yeni olan bilgilerin ağ üzerindeki diğer switch'lere bildirilmesi sağlanmış olur.

VTP yapısını için gerekli olanlar:
** VTP Domain: vtp domain sayesinde bir etki alanı oluşturarak, diğer switch'leri de bu etki alanına toplamış oluyoruz.
** VTP Password: vtp password sayesinde örneğin ortama başka bir switch eklendiğinde, VTP ile tüm VLAN bilgisinin bu yeni switch üzerine de geçmesini engellemiş oluruz. Yeni takacağınız switch'inizi çok daha farklı bir amaç için kullanacak olabilirsiniz. Yeni takacağınız switch'inize bu vtp password bilgisini girmediğiniz sürece, Vlan bilgilerini alamayacaktır.
** VTP Version 2:
** VTP Mode: Üç tane vtp mode bulunmaktadır. 

Bunlar;
1. VTP Server Mode: Bu modda çalışan switch'de VLAN oluşturulur ve silinebilir. Ayrıca Layer 3'te VLAN interface konfigürasyonu, Server modda olan switch'de yapılandırılır. Multilayer Switch üzerinde Server Mode varsayılan olarak tanımlıdır.
2. VTP Transparent Mode: Bu modda çalışan switchler, VTP'den VLAN bilgilerini alarak bilgileri kendi üzerinde tutmadan diğer switch'lere iletir. Bir nevi köprü görevi görmektedir.
3. VTP Client Mode: Bu modda olan switch'ler trunk portları üzerinden VLAN listesini alıp, kendi üzerlerinde bu bilgileri kaydederek VLAN bilgilerini taşırlar.

show vlan komutu ile Vlan'leri görüntülemek istediğimizde, Backbone Switch üzerinde oluşturduğumuz VLAN'lerin katlardaki Layer2 Switch'lere erişMEdiğini görebiliyorum. Oluşturulan Vlan bilgilerinin, Layer3 backbone switch üzerinden katlardaki Layer2 Switch'lere de tanımlanabilmesi için, katlardaki switch'lere de VTP ayarının yapılması gerekmektedir.

show vlan komutu ile KAT3-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

show vlan komutu ile KAT2-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

show vlan komutu ile KAT1-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

Şimdeki adımımızda, Backbone Switch üzerinde oluşturduğumuz VLAN'lerin katlardaki Layer2 Switch'lere erişmesini sağlamak için VTP bilgilerini gireceğiz;

Backbone Switch Üzerinde VTP Yapılandırma:

BACKBONE-SWITCH#
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#vtp domain firatboyan.com
Changing VTP domain name from NULL to firatboyan.com
BACKBONE-SWITCH(config)#vtp password 112233
Setting device VLAN database password to 11223
BACKBONE-SWITCH(config)#vtp version 2
BACKBONE-SWITCH(config)#vtp mode server

Device mode already VTP SERVER.
BACKBONE-SWITCH(config)#do write
Building configuration...
[OK]
BACKBONE-SWITCH(config)#
BACKBONE-SWITCH#


vlan yapılandırma, vlan konfigürasyonu

KAT3 Switch Üzerinde VTP Yapılandırma:

Layer2 Switch'ler üzerinde, Layer3 switch üzerinde yaptığımız gibi vtp domain bilgisini girmiyoruz. Domain sadece bir kez ve Layer3 switch üzerinde oluşturulur. Bunu, Active Directory Domain sistemine benzetebiliriz. Ek olarak, Layer2 Switch'ler üzerinde vtp mode'u server olarak giremeyiz. vtp mode server, ortamda sadece bir tane bulunabilir.

KAT3-SWITCH>enable
KAT3-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT3-SWITCH(config)#vtp domain firatboyan.com
Domain name already set to firatboyan.com.
Domain zaten firatboyan.com olarak yapılandırılmış durumda. Bunu görebilmeniz için özellikle Vtp domain firatboyan.com yazdım.
KAT3-SWITCH(config)#vtp password 112233
KAT3-SWITCH(config)#vtp version 2
KAT3-SWITCH(config)#vtp mode client

Setting device to VTP CLIENT mode.
KAT3-SWITCH(config)#do write
Building configuration...
[OK]
KAT3-SWITCH(config)#

vlan yapılandırma, vlan konfigürasyonu

KAT2 Switch Üzerinde VTP Yapılandırma:

Layer2 Switch'ler üzerinde, Layer3 switch üzerinde yaptığımız gibi vtp domain bilgisini girmiyoruz. Domain sadece bir kez ve Layer3 switch üzerinde oluşturulur. Bunu, Active Directory Domain sistemine benzetebiliriz. Ek olarak, Layer2 Switch'ler üzerinde vtp mode'u server olarak giremeyiz. vtp mode server sadece ortamda sadece bir tane bulunabilir.

KAT2-SWITCH>enable
KAT2-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT2-SWITCH(config)#vtp domain firatboyan.com
Domain name already set to firatboyan.com.

Domain zaten firatboyan.com olarak yapılandırılmış durumda. Bunu görebilmeniz için özellikle Vtp domain firatboyan.com yazdım.
KAT2-SWITCH(config)#vtp password 112233
KAT2-SWITCH(config)#vtp version 2
KAT2-SWITCH(config)#vtp mode client

Setting device to VTP CLIENT mode.
KAT2-SWITCH(config)#do write
Building configuration...
[OK]
KAT3-SWITCH(config)#

vlan yapılandırma, vlan konfigürasyonu

KAT1 Switch Üzerinde VTP Yapılandırma:

Layer2 Switch'ler üzerinde, Layer3 switch üzerinde yaptığımız gibi vtp domain bilgisini girmiyoruz. Domain sadece bir kez ve Layer3 switch üzerinde oluşturulur. Bunu, Active Directory Domain sistemine benzetebiliriz. Ek olarak, Layer2 Switch'ler üzerinde vtp mode'u server olarak giremeyiz. vtp mode server sadece ortamda sadece bir tane bulunabilir.

KAT1-SWITCH>enable
KAT1-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT1-SWITCH(config)#vtp domain firatboyan.com
Domain name already set to firatboyan.com.
Domain zaten firatboyan.com olarak yapılandırılmış durumda. Bunu görebilmeniz için özellikle Vtp domain firatboyan.com yazdım.
KAT1-SWITCH(config)#vtp password 112233
KAT1-SWITCH(config)#vtp version 2
KAT1-SWITCH(config)#vtp mode client

Setting device to VTP CLIENT mode.
KAT1-SWITCH(config)#do write
Building configuration...
[OK]
KAT3-SWITCH(config)#

vlan yapılandırma, vlan konfigürasyonu

VTP yapılandırmasından sonra, Show Vlan komutu ile Vlan'leri görüntülemek istediğimizde, Backbone Switch üzerinde oluşturduğumuz VLAN'lerin katlardaki Layer2 Switch'lere artık eriştiğini görebiliyorum.

Show Vlan komutu ile KAT3-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

Show Vlan komutu ile KAT2-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

Show Vlan komutu ile KAT1-SWITCH Üzerinde VLAN durumu:

vlan yapılandırma, vlan konfigürasyonu

VLAN'LERİ SWITCHPORT'LARA TANIMLAMA

Oluşturmuş olduğumuz VLAN'leri, TRUNK yapısı ile KAT1, KAT2, ve KAT3'teki Layer2 Switch'lere tanımladıktan sonra, bu Vlan bilgilerini Switch Port'lara tanımlayacağız.

KAT3 Switch Üzerinde Switch Port VLAN Tanımalama:

3. Katta IT ve IK olmak üzere iki farklı departman bulunuyor.
Bu departmana ait VLAN bilgileri IT için Vlan 10, IK için ise Vlan 20 şeklindedir.

IT için Vlan 10, fastEthernet 0/1'den başlayarak gigabitEthernet 0/10'a kadar olan tüm port'ları Vlan 10 için atayacağız.
Daha sonra,
IK için Vlan 20, fastEthernet 0/11'den başlayarak gigabitEthernet 0/20'ye kadar olan tüm port'ları Vlan 20 için atayacağız.

Switch portlarda vlan oluşturma

KAT3-SWITCH>enable
KAT3-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT3-SWITCH(config)#interface range fastEthernet 0/1-10
KAT3-SWITCH(config-if-range)#switchport mode access
KAT3-SWITCH(config-if-range)#switchport access Vlan 10
KAT3-SWITCH(config-if-range)#exit

KAT3-SWITCH(config)#interface range fastEthernet 0/11-20
KAT3-SWITCH(config-if-range)#switchport mode access
KAT3-SWITCH(config-if-range)#switchport access vlan 20
KAT3-SWITCH(config-if-range)#exit
KAT3-SWITCH(config)#do write

Building configuration...
[OK]
KAT3-SWITCH(config)#

** interface range fastEthernet 0/1-10 komutu ile, fastEthernet 0/1'den başlayarak toplu bir şekilde fastEthernet 0/10'a kadar olan port'lara atmak için seçiyorum.

** switchport mode access komutu ile seçilen port'un bir erişim portu olduğu belirtilir.

** switchport access vlan 10 komutu ile port'un hangi vlan’a erişim portu olduğu belirlenir. Aynı işlem Vlan 20 için de tekrarlanacaktır.

vlan yapılandırma, vlan konfigürasyonu

KAT2 Switch Üzerinde Switch Port VLAN Tanımalama:

2. Katta ARGE ve MUHENDISLIK olmak üzere iki farklı departman bulunuyor.
Bu departmana ait VLAN bilgileri ARGE için Vlan 30, MUHENDISLIK için ise Vlan 40 şeklindedir.

ARGE için Vlan 30, fastEthernet 0/1'den başlayarak gigabitEthernet 0/10'a kadar olan tüm port'ları Vlan 30 için atayacağız.
Daha sonra,
MUHENDISLIK içinvVlan 40, fastEthernet 0/11'den başlayarak gigabitEthernet 0/20'ye kadar olan tüm port'ları Vlan 40 için atayacağız.

Switch portlarda vlan oluşturma

KAT2-SWITCH>enable
KAT2-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT2-SWITCH(config)#interface range fastEthernet 0/1-10
KAT2-SWITCH(config-if-range)#switchport mode access
KAT2-SWITCH(config-if-range)#switchport access Vlan 30
KAT2-SWITCH(config-if-range)#exit

KAT2-SWITCH(config)#interface range fastEthernet 0/11-20
KAT2-SWITCH(config-if-range)#switchport mode access
KAT2-SWITCH(config-if-range)#switchport access vlan 40
KAT2-SWITCH(config-if-range)#exit
KAT2-SWITCH(config)#do write

Building configuration...
[OK]
KAT3-SWITCH(config)#

** interface range fastEthernet 0/1-10 komutu ile, fastEthernet 0/1'den başlayarak toplu bir şekilde fastEthernet 0/10'a kadar olan port'lara atmak için seçiyorum.

** switchport mode access komutu ile seçiklen portun bir erişim portu olduğu belirtilir.

** switchport access vlan 30 komutu ile port'un hangi vlan’a erişim portu olduğu belirlenir. Aynı işlem Vlan 40 için de tekrarlanacaktır.

vlan yapılandırma, vlan konfigürasyonu

KAT1 Switch Üzerinde Switch Port VLAN Tanımalama:

3. Katta FINANS ve YONETIM olmak üzere iki farklı departman bulunuyor.
Bu departmana ait VLAN bilgileri FINANS için Vlan 50, YONETIM için ise Vlan 60 şeklindedir.

FINANS için Vlan 50 fastEthernet 0/1'den başlayarak gigabitEthernet 0/10'a kadar olan tüm port'ları Vlan 50 için atayacağız.
Daha sonra,
YONETIM için Vlan 60 fastEthernet 0/11'den başlayarak gigabitEthernet 0/20'ye kadar olan tüm port'ları Vlan 60 için atayacağız.

Switch portlarda vlan oluşturma

KAT1-SWITCH>enable
KAT1-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
KAT1-SWITCH(config)#interface range fastEthernet 0/1-10
KAT1-SWITCH(config-if-range)#switchport mode access
KAT1-SWITCH(config-if-range)#switchport access Vlan 50
KAT1-SWITCH(config-if-range)#exit
KAT1-SWITCH(config)#interface range fastEthernet 0/11-20
KAT1-SWITCH(config-if-range)#switchport mode access
KAT1-SWITCH(config-if-range)#switchport access vlan 60
KAT1-SWITCH(config-if-range)#exit
KAT1-SWITCH(config)#do write

Building configuration...
[OK]
KAT3-SWITCH(config)#

** interface range fastEthernet 0/1-10 komutu ile, fastEthernet 0/1'den başlayarak toplu bir şekilde fastEthernet 0/10'a kadar olan port'lara atmak için seçiyorum.

** switchport mode access komutu ile seçiklen portun bir erişim portu olduğu belirtilir.

** switchport access vlan 50 komutu ile port'un hangi vlan’a erişim portu olduğu belirlenir. Aynı işlem Vlan 60 için de tekrarlanacaktır.

vlan yapılandırma, vlan konfigürasyonu

Katlardaki Layer2 Switch'ler üzerinde Switch Port VLAN Tanımalama işlemlerini tamamladıktan sonra, Show Vlan komutu ile Vlan'leri görüntülemek istediğimizde, VLAN'lerin ilgili Switch Port'lara atandığını görebiliyorum.

Show Vlan komutu ile KAT3-SWITCH Üzerinde Switch Port'lara atanan Vlan'ler:

vlan yapılandırma, vlan konfigürasyonu

Show Vlan komutu ile KAT2-SWITCH Üzerinde Switch Port'lara atanan Vlan'ler:

vlan yapılandırma, vlan konfigürasyonu

Show Vlan komutu ile KAT1-SWITCH Üzerinde Switch Port'lara atanan Vlan'ler:

vlan yapılandırma, vlan konfigürasyonu

VLAN'LERE IP ATAMASI YAPMA VE VLAN'LER ARASI ROUTING YAPILANDIRMA

Buraya kadar olan adımlarımızda, VLAN oluşturma işlemlerini gerekli tüm adımları ile birlikte başarılı bir şekilde tamamladık.

Son adım olarak, Bu VLAN'lere IP ataması yaparak, VLAN'ler arasında ROUTING (Yönlendirme) işlemi gerçekleştirmek ve bu farklı network'lerin birbirleri ile iletişime geçebilmelerini sağlamamız olacatır.

Bu routing (yönlendirme) işlemini Backbone Switch Üzerinde gerçekleştireceğim.

  • Backbone Switch Üzerinde VLAN'lere IP ataması ve VLAN'ler arasında IP ROUTING işlemi gerçekleştirmeden önce, Server üzerinde ilgili DHCP Scope'larımı oluşturarak PC'lerin, VLAN'lera atanan IP bloklarından IP almalarını sağlayacağım.

Server Bilgisayara Static IP Atama

Server'ımı Vlan 10'a dahil etmek istiyorum. Siz istediğiniz başka bir Vlan seçebilirsiniz. Server'ıma Static IP olarak 10.10.10.100 IP adresini atıyorum.

vlan yapılandırma, vlan konfigürasyonu

VLAN'ler için DHCP SCOPE Yapılandırma

Vlan 10 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

Vlan 20 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

Vlan 30 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

Vlan 40 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

Vlan 50 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

Vlan 60 için DHCP Scope yapılandırma işlemini tamamladım.

vlan yapılandırma, vlan konfigürasyonu

VLAN IP ATAMASI & IP ROUTING

Server üzerinde ilgili DHCP Scope'larımı oluşturduktan sonra, Backbone Switch Üzerinde VLAN'lere IP ataması ve VLAN'ler arasında IP ROUTING işlemi gerçekleştirme işlemine geçiyorum.,

Yapılması gereken işlemlerin başında IP ROUTING komutu gelmektedir. Bu komutu yazmazsanız, VLAN'ler haberleşmezler.

NOT: Bu komut, sadece bir kez yazılmalıdır. Her VLAN IP ataması işlemi için tekrar tekrar ip routing komutu yazılMAyacaktır.


Daha sonrasında ise, ip address komutu ile VLAN'lere tek tek ip ataması yaparak, ilgili VLAN'lere Default Gateway ataması işlemini yapacağız. Bu işlemi yaparken, ip helper-address komutu ile de ilgili DHCP scope'undan da her bir client'ın ip adreslerini almalarını sağlamamız gerekiyor.

ip address 10.10.XX.254 255.255.255.0 

Bu VLAN ip adres tanımlaması, L3 Backbone Switch'in ilgili VLAN'e bakan IP'si yani
Default Gateway'idir.

ip adress 10.10.10.254 255.255.255.0 VLAN 10 Default Gateway'i
ip adress 10.10.20.254 255.255.255.0 VLAN 20 Default Gateway'i
ip adress 10.10.30.254 255.255.255.0 VLAN 30 Default Gateway'i
ip adress 10.10.40.254 255.255.255.0 VLAN 40 Default Gateway'i
ip adress 10.10.50.254 255.255.255.0 VLAN 50 Default Gateway'i
ip adress 10.10.60.254 255.255.255.0 VLAN 50 Default Gateway'i

ip helper-address 10.10.10.100 DHCP SUNUCU IP'sidir.

Vlan 10 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#ip routing
BACKBONE-SWITCH(config)#interface vlan 10

%LINK-5-CHANGED: Interface Vlan10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.10.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


vlan yapılandırma, vlan konfigürasyonu

Vlan 20 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#interface vlan 20
%LINK-5-CHANGED: Interface Vlan20, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.20.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


Vlan 30 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#interface vlan 30
%LINK-5-CHANGED: Interface Vlan30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan30, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.30.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


Vlan 40 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#interface vlan 40
%LINK-5-CHANGED: Interface Vlan40, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan40, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.40.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


Vlan 50 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#interface vlan 50
%LINK-5-CHANGED: Interface Vlan50, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan50, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.50.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


Vlan 60 için IP ataması:

BACKBONE-SWITCH>enable
BACKBONE-SWITCH#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.
BACKBONE-SWITCH(config)#interface vlan 60
%LINK-5-CHANGED: Interface Vlan60, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan60, changed state to up
BACKBONE-SWITCH(config-if)#ip address 10.10.60.254 255.255.255.0
BACKBONE-SWITCH(config-if)#ip helper-address 10.10.10.100
BACKBONE-SWITCH(config-if)#exit
BACKBONE-SWITCH(config)#do write


vlan yapılandırma, vlan konfigürasyonu

Client PC'lerin DHCP'den IP Almaları

Backbone Switch Üzerinde VLAN'lere IP ataması ve VLAN'ler arasında IP ROUTING işlemlerimi gerçekleştirdim. Şimdi de, PC'lerimin DHCP Server üzerinden IP almalarını sağlamak üzere NIC yapılandırmalarını Static'ten DHCP'ye geçiriyorum.

VLAN 10'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini ilgili DHCP Scope üzerindeki 10.10.10.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

VLAN 20'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini 10.10.20.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

VLAN 30'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini 10.10.30.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

VLAN 40'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini 10.10.40.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

VLAN 50'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini 10.10.50.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

VLAN 60'da bulunan bir PC'nin DHCP'den IP aldığını görebiliyorum. Diğer PC'ler de başarışı bir şekilde IP'lerini 10.10.60.0 Network'ünden almıştır.

vlan yapılandırma, vlan konfigürasyonu

Vlan Yapılandırılmış bir Network Ortamında Network Trafiği

Makalemizin ilk başında Vlan YapılandırılMAmış bir Network Ortamında Network Trafiğini izlemiş, ağ üzerindeki data paketlerinin, tüm sisteme nasıl dağıldığı ve ağ ortamındaki data paketlerinin bu şekilde broadcast ile tüm network'e yayıldığını gözlemleyip, gereksiz broadcast oluşturuğunu gözlemlemiştik.

Artık yağımızda VLAN yapılandırması mevcut. Aynı yapıyı bu sefer de VLAN ortamında inceleyelim.

3. Katta bulunan PC59 numaralı bilgisayardan, 1. kattaki PC20 numaralı bilgisayara bir data paketi yolluyorum.

Paketlerin rahatlıkla izlenebilmesi için, ARP protokolünü de devreye aldım. Bu iki bilgisayar ilk kez haberleşecekleri için, ARP Request paketindeki Destination Mac Address bilgisi FF-FF-FF-FF-FF-FF olduğu için, PC59'dan çıkan data paketi önce kendi VLAN network'ünde dolaşacak ve data paketini KAT3 Switch'e, oradan da Backbone Switch'e yollayarak iligli VLAN'e yollanması için ip routing yapacaktır.

vlan yapılandırma, vlan konfigürasyonu
vlan yapılandırma, vlan konfigürasyonu

Görüldüğü gibi PC59'dan çıkan data paketi, ARP Request içindeki Destination Mac Address bilgisi FF-FF-FF- FF-FF-FF olduğu için, ilk önce 3. katta sadece VLAN 20'ye ait tüm bilgisayarlara ulaştırıldı.

Bu data paleti, VLAN 10'a ait bilgisayarlara yönlendirilMEdi. Boradcast sadece VLAN 20 network'ünde yaşandı. İlgili data paketi, ARP Request ile gelen data paketindeki Destination IP adresi kendilerine ait olmadığı için, Vlan20'deki tüm bilgisayarlar data paketini reddetti.

vlan yapılandırma, vlan konfigürasyonu

Aynı data paketi, 2. kattaki hiçbir Vlan Network'üne uğramadı.

PC59'dan çıkan data paketi, ARP Request içindeki Destination Mac Address bilgisi FF-FF-FF- FF-FF-FF olduğu için, 1. katta sadece VLAN 60'a ait bilgisayarlara ulaştırıldı. Bu data paketi, VLAN 50'ye ait bilgisayarlara yönlendirilmedi.

Boradcast sadece VLAN 60 network'ünde yaşandı. İlgili data paketi, ARP Request ile gelen data paketindeki Destination IP adresi kendilerine ait olmadığı için, Vlan60'taki PC20 hariç tüm bilgisayarlar data paketini reddetti.

PC20, ARP Request ile gelen data paketindeki Destination IP adresi kendine ait olduğu için için paketi aldı.


vlan yapılandırma, vlan konfigürasyonu
vlan yapılandırma, vlan konfigürasyonu

İşte bu örnekte görüldüğü gibi, Vlan ile segmentlere bölünmüş bir network ortamında data paketleri, bu şekilde sadece ilgili VLAN'ler içindeki network'lere ilk data paketi gönderiminde (daha önce hiç haberleşmemiş bilgisayarlar için) broadcast ile yayılmakta, gereksiz yere bir trafik oluşMAmaktadır.

Bu konu ile bağlantılı olarak,aynı yapı baz alınmak suretiyle VLAN'le Yapılandırılmış iki lokasyonun birbirleri arasında nasıl yönlendirildiğini (route edildiğini) ve Vlan network'lerinden dışarıya (LAN'dan WAN'a) data paketlerinin nasıl aktarıldığını öğrenmek için,  VLAN'le Yapılandırılmış Lokasyonların Routing (yönlendirme) İşlemleri makalemi de okumanızı tavsiye ederim.

Faydalı olması dileğiyle...
 


Beğendiğiniz içerikleri facebook, twitter, g+1 veya LinkedIn üzerinden paylaşarak makalelerin daha fazla kişi tarafından görüntülenmesine yardımcı olabilirsiniz.


Her türlü görüş ve önerilerinizi aşağıdaki YORUM panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.

YAZAR HAKKINDA:

Microsoft Certified Trainer-MCT.
Microsoft Certified Solution Expert-MCSE: Cloud Platorm and Infrastructure.

Adım Fırat Boyan. Bilgi Teknolojileri Sistem ve Ağ Mühendisiyim. 1985 Alanya doğumluyum. 2008 yılından beri İstanbul'da yaşıyorum. 15 yıldır Bilişim Teknolojileri sektöründeyim.

2003 yılında lise eğitimimden sonra bir bilgisayar teknik servisinde önce stajyer, sonrasında ise teknik servis teknisyeni olarak başladığım bilişim sektörü çalışma hayatıma, üniversite eğitimimi tamamladıktan sonra, çeşitli şirketlerin bilgi işlem departmanlarında Sistem Destek Uzmanı, IT Uzmanı, IT Sistem Sorumlusu ve IT Sistem Yöneticisi olarak devam ettim ve çok çeşitli projelerde aktif rol alıp Sistem ve Network alanında ciddi deneyimler edinerek bilgime bilgi, tecrübeme tecrübe kattım.

JP. Morgan Chase Bank'ta Sistem Uzmanı ve Analisti olarak görev yapıyor, Türkiye’nin bilişim eğitimleri alanında hizmet veren Bilgi Tekolojileri Eğitim Merkezleri olan Bilge Adam’da MCT-Microsoft Certified Trainer (Microsoft Sertifikalı Eğitmen) ünvanı ile Sistem, Network ve Güvenlik eğitimleri veriyor, kurumsal firmalara Bilişim Teknolojileri Danışmanlık Hizmetleri sunuyorum.

Sertifikalarım:

MCT (Microsoft Certified Trainer)- 2016/2017 - 2017/2018 - 2018/2019
MCPS (Microsoft Certified Professional)
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2012
MCSE (Microsoft Certified Solutions Expert)- Server Infrastructure
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2017
MCSE (Microsoft Certified Solutions Expert)- Messaging
MCSE (Microsoft Certified Solutions Expert)- Productivity 2017
MS (Microsoft Specialist)- Designing and Deploying Microsoft Exchange Server 2016
MCSA (Microsoft Certified Solutions Associate)- Windows Server 2016
MCSE (Microsoft Certified Solutions Expert)- Cloud Platform and Infrastructure 2018
MCSE (Microsoft Certified Solutions Expert)- Productivity 2018




comment YORUMLAR
Bu makaleye 14 yorum yapıldı.

Her türlü görüş ve önerilerinizi aşağıdaki yorum panelinden bırakabilir, kafanıza takılanları veya merak ettiklerinizi sorabilirsiniz.


YORUM YAZ

   
  
(yorum onay bildirimi için gereklidir, yayınlanmaz.)
  750 Karakter yazabilirsiniz.
   
Güvenlik kodunu BÜYÜK harflerle giriniz.

* Yorumlar, onaylandıktan sonra yayınlanmaktadır.




YAPILAN YORUMLAR


09-06-2018


Metin

multilayer switch portlarını vlan olarak nasıl tanımlayabilirim. örneğin multilayer sw fast0/2 portu vlan 10 olsun gibi


18-06-2018


Metin

http://dosya.co/n9eg83srqse6/backbone_vlan.pkt.html linki unutmuşum özür dilerim

18-06-2018


Fırat Boyan

Link nerede?

18-06-2018


Metin

merhaba; rica etsem linkteki örneğe bakabilr misiniz. Backbone üzerinde vlan oluşturma işlemleri. Dhcp vlana göre ip dağıtması gerekirken scope ayrımı yapmadan tek gruptan dağıtıyor. İyi çalışmalar

11-06-2018


Fırat Boyan

ip routing komutu, backbone SW üzerinde yapılır. Trunk ise, birden fazla SW kullanılan yapılarda bir SW üzerinden birden fazla Vlan e ait frame bilgilerinin geçmesi için gereklidir. Yani birden fazla SW ve VLAN varsa, Trunk şarttır. Faklı model olması farklılık göstermez.

10-06-2018


Metin

Peki portlar trunk mı olmalı, routing olmalı mı yine. Gerçek bir yapıda backbone cisco, kenar swler hp, cisco ve baska bir iki sw marka daha olabilir kontrolsüz bir büyüme var çünkü.bu sekilde vlan yapmada sıkıntı çıkar mı omurga üzerinde. Teşekkür ederim

10-06-2018


Fırat Boyan

Aslında makalede geçenden çok da farklı değil. Makalede VLANleri L3 Switch üzerinde tanımlayıp, VTP yardımıyla alt L2 Switchlere dağıttık ve port atamalarını bu swtichlerde yaptık. Senin sorduğun doruda VLAN yapılandırlamaları yine L3 SW üzerinde yapılacak ancak VTP kullanmaya gerek kalmadan port atamalarını direkt olarak yine L3 SW üzerinde L2 SWlerde yaptığımız gibi yapman lazım. Hepsi bu.


28-11-2017


Erdi AY

Physical desktop vs yazan ss aldığınız programın adı nedir



28-05-2017


Süleyman yurt

merhaba; bir konu bu kadar güzel anlatılır . eline yüregine saglık hocam. saygılarımla.


27-06-2017


Fırat Boyan

Süleyman Bey, teşekkürler.


13-12-2016


rafet

Elinize sağlık Fırat Hocam. Çok faydalı oldu.


27-06-2017


Fırat Boyan

Rica ederim Rafetçim. Faydalı olduysa ne mutlu.


07-12-2016


hakan kaplanoğul

Teşekkürler, faydalı ve güzel bir makale olmuş.


27-06-2017


Fırat Boyan

Beğenmenize sevindim Hakan Bey






BT EĞİTİM

Kurumsal eğitimler veren bir Microsoft Sertifikalı IT eğitmeniyim. IT Danışmanlık Hizmetleri verdiğim kurumlarda sürekli olarak, bilgi işlem personellerinin yaptığı işleri genelde ezbere ve neden yaptıklarını tam olarak kavrayamadan, bilmeden yaptıklarına şahit oldum. Böyle durumlarda da genelde firmalar, çalışanlarına IT eğitimleri aldırarak, daha profesyonel ve biliçli personeller istihdam etmektedirler. Sizler de kurumunuzda istihdam ettirdiğiniz bilgi işlem personellerinize IT Eğimleri aldırarak, kurumsal olarak yeni teknolojilere daha güçlü ve bilinçli geçişler yaparak ya da mevcut teknolojiler ile yapılandırılmış alt yapınızın bilgi işlem personelleriniz tarafından bilinçli ve profesyonel olarak ayakta tutmasını ve yürütmesini sağlayabilirsiniz.

Detaylar »





BT DANIŞMANLIK

Kendi bünyesinde IT departmanı isitihdam etmeyen ve bu hizmeti danışmanlık kapsamında outsource olarak alan firmalar, bilgisayar sistemlerinin bakımı ve onarımı için profesyonellerden bakım anlaşması kapsamında hizmet talep etmektedirler. Bilişim sektöründe danışmanlık önemli bir konudur. Bu nedenle, işinin ehli olmayan kişilere sisteminizi emanet edemezsiniz. Profesonel IT Uzmanı olarak; işletmelerin Kurumsal IT ihtiyaçlarına yönelik IT ekipmanlarının ve sistemlerinin kurulum,bakım ve konfigürasyonlarının yapılması hizmetlerini sunuyorum.

Detaylar »





İLETİŞİM

Taleplerinizi iletişim formu aracılığıyla direkt olarak bana iletebilirsiniz.
İletilerinize cevap verebilmem için mutlaka gerçeli bir e-posta adresi girin. Gönderdiğiniz iletiler en kısa sürede cevaplanacaktır. Girdiğiniz bilgiler asla üçüncü taraflarla paylaşılmaz. İletilerinizi iletişim formu aracılığı ile direkt olarak iletebileceğiniz gibi, kendi e-posta sunucunuzu kullanarak da mail adresime iletebilirsiniz.

İletişim Formu »